package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\([^$]*?\)`)
var str = `I need a Regular Expression that can match the words that are methods, for example:
Project.name.toUpper().toBase64()
matches: toUpper() and toBase64()
or
Project.name.toLower(1)
matches: toLower(1)
I already have this but it only matches the first found (toUpper()):
Pattern patternParenthesis = Pattern.compile("\\(([^)]+)*[)()]*");`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}