# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+\([^$]*?\)"
test_str = ("I need a Regular Expression that can match the words that are methods, for example:\n\n"
"Project.name.toUpper().toBase64()\n\n"
"matches: toUpper() and toBase64()\n\n"
"or\n\n"
"Project.name.toLower(1)\n\n"
"matches: toLower(1)\n\n"
"I already have this but it only matches the first found (toUpper()):\n\n"
"Pattern patternParenthesis = Pattern.compile(\"\\\\(([^)]+)*[)()]*\");")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.