// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+\([^$]*?\)").unwrap();
let string = "I need a Regular Expression that can match the words that are methods, for example:
Project.name.toUpper().toBase64()
matches: toUpper() and toBase64()
or
Project.name.toLower(1)
matches: toLower(1)
I already have this but it only matches the first found (toUpper()):
Pattern patternParenthesis = Pattern.compile(\"\\\\(([^)]+)*[)()]*\");";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}