use strict;
my $str = 'I need a Regular Expression that can match the words that are methods, for example:
Project.name.toUpper().toBase64()
matches: toUpper() and toBase64()
or
Project.name.toLower(1)
matches: toLower(1)
I already have this but it only matches the first found (toUpper()):
Pattern patternParenthesis = Pattern.compile("\\\\(([^)]+)*[)()]*");';
my $regex = qr/\w+\([^$]*?\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}