# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"need".*{.*,?".*?":(".+?").*}/\1/;t' <<< "\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}
\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C:\"ZABCD1235\"}
\"need\" : {\"A\":\"ZABCD123\" : {a\"B\":\"ZABCD123\"
\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}"