#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""need".*{.*,?".*?":(".+?").*}"
Local $sString = ""skip" : {"A":"ABCD123","B":"ABCD1234","C":"ABCD1235"}" & @CRLF & _
"" & @CRLF & _
""need" : {"A":"ZABCD123","B":"ZABCD1234","C:"ZABCD1235"}" & @CRLF & _
"" & @CRLF & _
""need" : {"A":"ZABCD123" : {a"B":"ZABCD123"" & @CRLF & _
"" & @CRLF & _
""ignore" : {"A":"SABCD123","B":"SABCD1234","C":"SABCD1235"}"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)