// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""need".*{.*,?".*?":(".+?").*}"#).unwrap();
let string = "\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}
\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C:\"ZABCD1235\"}
\"need\" : {\"A\":\"ZABCD123\" : {a\"B\":\"ZABCD123\"
\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}