using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""need"".*{.*,?"".*?"":("".+?"").*}";
string substitution = @"\1";
string input = @"""skip"" : {""A"":""ABCD123"",""B"":""ABCD1234"",""C"":""ABCD1235""}
""need"" : {""A"":""ZABCD123"",""B"":""ZABCD1234"",""C:""ZABCD1235""}
""need"" : {""A"":""ZABCD123"" : {a""B"":""ZABCD123""
""ignore"" : {""A"":""SABCD123"",""B"":""SABCD1234"",""C"":""SABCD1235""}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}