re = /"need".*{.*,?".*?":(".+?").*}/
str = '"skip" : {"A":"ABCD123","B":"ABCD1234","C":"ABCD1235"}
"need" : {"A":"ZABCD123","B":"ZABCD1234","C:"ZABCD1235"}
"need" : {"A":"ZABCD123" : {a"B":"ZABCD123"
"ignore" : {"A":"SABCD123","B":"SABCD1234","C":"SABCD1235"}'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result