const regex = /"need".*{.*,?".*?":(".+?").*}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"need".*{.*,?".*?":(".+?").*}', '')
const str = `"skip" : {"A":"ABCD123","B":"ABCD1234","C":"ABCD1235"}
"need" : {"A":"ZABCD123","B":"ZABCD1234","C:"ZABCD1235"}
"need" : {"A":"ZABCD123" : {a"B":"ZABCD123"
"ignore" : {"A":"SABCD123","B":"SABCD1234","C":"SABCD1235"}`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);