#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)"
Local $sString = "Contact_Number---------------Name" & @CRLF & _
"" & @CRLF & _
"land="1234" Phone="324"------Kumar" & @CRLF & _
"land="3254" phone="458"------Ramu" & @CRLF & _
"" & @CRLF & _
"Now what i want is Phone number of each and every person like below," & @CRLF & _
"Contact_Number---------------Name" & @CRLF & _
"" & @CRLF & _
"Phone="324"----------------Kumar" & @CRLF & _
"phone="458"-----------------Ramu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")