import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[Pp]hone=\"(?<Contact_Number>.+?)\"-+(?<Name>.+)";
final String string = "Contact_Number---------------Name\n\n"
+ "land=\"1234\" Phone=\"324\"------Kumar\n"
+ "land=\"3254\" phone=\"458\"------Ramu\n\n"
+ "Now what i want is Phone number of each and every person like below,\n"
+ "Contact_Number---------------Name\n\n"
+ "Phone=\"324\"----------------Kumar\n"
+ "phone=\"458\"-----------------Ramu";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}