// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)"#).unwrap();
let string = "Contact_Number---------------Name
land=\"1234\" Phone=\"324\"------Kumar
land=\"3254\" phone=\"458\"------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone=\"324\"----------------Kumar
phone=\"458\"-----------------Ramu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}