re = /[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)/m
str = 'Contact_Number---------------Name
land="1234" Phone="324"------Kumar
land="3254" phone="458"------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone="324"----------------Kumar
phone="458"-----------------Ramu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end