use strict;
my $str = 'Contact_Number---------------Name
land="1234" Phone="324"------Kumar
land="3254" phone="458"------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone="324"----------------Kumar
phone="458"-----------------Ramu';
my $regex = qr/[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}