const regex = /[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)', 'gm')
const str = `Contact_Number---------------Name
land="1234" Phone="324"------Kumar
land="3254" phone="458"------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone="324"----------------Kumar
phone="458"-----------------Ramu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}