$re = '/[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)/m';
$str = 'Contact_Number---------------Name
land="1234" Phone="324"------Kumar
land="3254" phone="458"------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone="324"----------------Kumar
phone="458"-----------------Ramu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);