using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Pp]hone=""(?<Contact_Number>.+?)""-+(?<Name>.+)";
string input = @"Contact_Number---------------Name
land=""1234"" Phone=""324""------Kumar
land=""3254"" phone=""458""------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone=""324""----------------Kumar
phone=""458""-----------------Ramu";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}