import Foundation
let pattern = #"[Pp]hone="(?<Contact_Number>.+?)"-+(?<Name>.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Contact_Number---------------Name
land="1234" Phone="324"------Kumar
land="3254" phone="458"------Ramu
Now what i want is Phone number of each and every person like below,
Contact_Number---------------Name
Phone="324"----------------Kumar
phone="458"-----------------Ramu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)