#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)href="([^"]+\?(page=([^&]*))[^"]+)""
Local $sString = "<a href="/page/page/categoria/page?page=2&publica=1" rel="next">2</a>" & @CRLF & _
"<a href="/page/page/categoria/page?page=&publica=1" rel="next">2</a>" & @CRLF & _
"<a href="/page/page/categoria/page?page=teste&publica=1" rel="next">2</a>" & @CRLF & _
"<a href="/page/page/categoria/page?page=home&method=add&publica=1" rel="next">2</a>" & @CRLF & _
"<a href="/page/page/categoria/page?page=about2&method=add&publica=1" rel="next">2</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")