import Foundation
let pattern = #"href="([^"]+\?(page=([^&]*))[^"]+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="/page/page/categoria/page?page=2&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=teste&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=home&method=add&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=about2&method=add&publica=1" rel="next">2</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)