const regex = /href="([^"]+\?(page=([^&]*))[^"]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="([^"]+\\?(page=([^&]*))[^"]+)"', 'gm')
const str = `<a href="/page/page/categoria/page?page=2&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=teste&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=home&method=add&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=about2&method=add&publica=1" rel="next">2</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}