use strict;
my $str = '<a href="/page/page/categoria/page?page=2&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=teste&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=home&method=add&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=about2&method=add&publica=1" rel="next">2</a>';
my $regex = qr/href="([^"]+\?(page=([^&]*))[^"]+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}