using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""([^""]+\?(page=([^&]*))[^""]+)""";
string input = @"<a href=""/page/page/categoria/page?page=2&publica=1"" rel=""next"">2</a>
<a href=""/page/page/categoria/page?page=&publica=1"" rel=""next"">2</a>
<a href=""/page/page/categoria/page?page=teste&publica=1"" rel=""next"">2</a>
<a href=""/page/page/categoria/page?page=home&method=add&publica=1"" rel=""next"">2</a>
<a href=""/page/page/categoria/page?page=about2&method=add&publica=1"" rel=""next"">2</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}