import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"([^\"]+\\?(page=([^&]*))[^\"]+)\"";
final String string = "<a href=\"/page/page/categoria/page?page=2&publica=1\" rel=\"next\">2</a>\n"
+ "<a href=\"/page/page/categoria/page?page=&publica=1\" rel=\"next\">2</a>\n"
+ "<a href=\"/page/page/categoria/page?page=teste&publica=1\" rel=\"next\">2</a>\n"
+ "<a href=\"/page/page/categoria/page?page=home&method=add&publica=1\" rel=\"next\">2</a>\n"
+ "<a href=\"/page/page/categoria/page?page=about2&method=add&publica=1\" rel=\"next\">2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}