// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="([^"]+\?(page=([^&]*))[^"]+)""#).unwrap();
let string = "<a href=\"/page/page/categoria/page?page=2&publica=1\" rel=\"next\">2</a>
<a href=\"/page/page/categoria/page?page=&publica=1\" rel=\"next\">2</a>
<a href=\"/page/page/categoria/page?page=teste&publica=1\" rel=\"next\">2</a>
<a href=\"/page/page/categoria/page?page=home&method=add&publica=1\" rel=\"next\">2</a>
<a href=\"/page/page/categoria/page?page=about2&method=add&publica=1\" rel=\"next\">2</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}