$re = '/href="([^"]+\?(page=([^&]*))[^"]+)"/m';
$str = '<a href="/page/page/categoria/page?page=2&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=teste&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=home&method=add&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=about2&method=add&publica=1" rel="next">2</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);