package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)href="([^"]+\?(page=([^&]*))[^"]+)"`)
var str = `<a href="/page/page/categoria/page?page=2&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=teste&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=home&method=add&publica=1" rel="next">2</a>
<a href="/page/page/categoria/page?page=about2&method=add&publica=1" rel="next">2</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}