using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+`";
string input = @"some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}