import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "`(?:[\\p{Zs}\\t]*(\\w+)[\\p{Zs}\\t]*)+`";
final String string = "some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}