re = /`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+`/m
str = 'some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end