package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+``)
var str = `some description \` match these_words th_is_wor \` or \`THIS_WOR thi_sqw\` a \`word_snake\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}