$re = '/`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+`/m';
$str = 'some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);