// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+`").unwrap();
let string = "some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}