import re
regex = re.compile(r"`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+`", flags=re.MULTILINE)
test_str = "some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")