use strict;
my $str = 'some description ` match these_words th_is_wor ` or `THIS_WOR thi_sqw` a `word_snake`';
my $regex = qr/`(?:[\p{Zs}\t]*(\w+)[\p{Zs}\t]*)+`/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}