# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+(?:\d+|[A-Za-z])$//gm;t' <<< "21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park"