using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?:\d+|[A-Za-z])$";
string substitution = @"";
string input = @"21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}