#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+(?:\d+|[A-Za-z])$"
Local $sString = "21st Townhouse 318" & @CRLF & _
"The Residences 6" & @CRLF & _
"Villanova Tower B" & @CRLF & _
"The Hills H" & @CRLF & _
"City Park"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)