import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(?:\\d+|[A-Za-z])$";
final String string = "21st Townhouse 318\n"
+ "The Residences 6\n"
+ "Villanova Tower B\n"
+ "The Hills H\n"
+ "City Park";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}