import Foundation
let pattern = #"\s+(?:\d+|[A-Za-z])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)