// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+(?:\d+|[A-Za-z])$").unwrap();
let string = "21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}