re = /\s+(?:\d+|[A-Za-z])$/m
str = '21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result