package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(?:\d+|[A-Za-z])$`)
var str = `21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}