use strict;
my $str = '21st Townhouse 318
The Residences 6
Villanova Tower B
The Hills H
City Park';
my $regex = qr/\s+(?:\d+|[A-Za-z])$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";