# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<desired_password>)/stuff/;t' <<< "bilbo <desired_password> <desired_password>"