re = /(<desired_password>)/
str = 'bilbo <desired_password> <desired_password>'
subst = 'stuff'
result = str.sub(re, subst)
# Print the result of the substitution
puts result