use strict;
my $str = 'bilbo <desired_password> <desired_password>';
my $regex = qr/(<desired_password>)/p;
my $subst = 'stuff';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";