package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<desired_password>)`)
var str = []byte(`bilbo <desired_password> <desired_password>`)
var substitution = []byte("stuff")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}