const regex = /(<desired_password>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<desired_password>)', '')
const str = `bilbo <desired_password> <desired_password>`;
const subst = `stuff`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);